Growth rate not calculated after 30+ min

Hi! I am doing a little experiment, and I changed in my config to have 0.5 samples per second. But the growth rate is still not calculated after more than half an hour (there is no data point in the Implied growth rate chart , even though I have hundreds of OD readings now).

I restarted the growth rate reading at some point, and it actually said “Completed OD normalizing metrics”. But there is still no data point in the growth rate chart

How do I troubleshoot this?

Hi @wendiy,

hm, that’s interesting. Can you SSH into the Pioreactor that’s having this issue and check pio logs to see if there’s any message being reported.

While you’re there, try

pio mqtt -t "pioreactor/+/+/growth_rate_calculating/#"

Does any real-time data show up there after a few seconds? (ctrl-c to exit)

Using 0.5 samples per second should be fine, I don’t see why that would cause a problem.

Having the same issue at the moment and the output of the following command suggested by CamDavidsonPilon is as follows:

For some reason the growth rate is set to be False

Huh, two users with this problem is strange.

For some reason the growth rate is set to be False

that’s okay, not an issue. That refers to if a client can externally update the growth-rate, and False means not allowed.

So nothing suspicious in the pio logs then? @sharknaro do you also have a different (faster) samples_per_second in your config?

Sorry for my personal mistake! It has been a long day and I was too tired to remember that the growth rate calculation starts after approximately half an hour! The plot started to be generated and there is no issue!

I’m guessing this is because you have very slow OD sample rate?

In the recent versions, there’s a new option in the config.ini you can set to take less samples initially for the baseline:


(You may not have samples_for_od_statistics in the section [growth_rate_calculating.config], but you can add it manually).

1 Like

Yes that is correct, we lowered it to every 30,3 seconds :))

Thanks for the information Cameron, I will check this tomorrow!