Worker start up issue

I’ve tried to initialize a worker and it seems to fail only after trying to connect to a leader.

I tried to SSH into the worker, but running the pio command gave the failed to find config.ini error.

I think fully rewriting the sd card with different names will solve it as a quick solution but I’ve seen this several times now and this has led to the leader failing on the config file as well, though I didn’t manage to document that case.
Is there a simple explanation for this I’m missing ?

For reference, I already had 1 worker successfully connect with the leader but the second one failed even though it had the same setup, only a different name.

Hi @cyanocapture,

hm, and when you SSH’ed into the worker, I’m guessing you used the password “raspberry” to log in? That would imply that the password is correct. (If you changed the default password from raspberry, that would explain it).

EDIT: also, the username on the worker is still pioreactor, right?

Can you try SSHing into the leader, and running:

/usr/local/bin/ worker4b raspberry

And posting the results?